CVE · Medium

CVE-2024-32791 — Premium Addons for Elementor – AI-Ready Elementor Addons, Widgets & Templates [premium-addons-for-elementor] < 4.10.26

CVE Vulnerability Type Severity Affected Fixed in Published Status
CVE-2024-32791 Premium Addons for Elementor – AI-Ready Elementor Addons, Widgets & Templates [premium-addons-for-elementor] < 4.10.26 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') Medium 6.5 < 4.10.26 4.10.26 2024-04-22 —

CVE-2024-32791

The Premium Addons for Elementor plugin contains a stored cross-site scripting vulnerability affecting versions up to 4.10.25, resulting from inadequate sanitization of user input and escaping of output in user-supplied attributes. Attackers with contributor-level permissions or higher can inject malicious scripts into pages, which execute when other users view those pages. The vulnerability was resolved in version 4.10.26.

Based on public CVE data (MITRE/NVD).

Scan your WordPress site free

No signup, no credit card — enter your URL and get a security report in seconds.